このフォームからは投稿できません。
name
e-mail
url
subject
comment
アクションエディター4 【質問・バグ報告】 BBS

トップ > サポート > アクションエディター4 【質問・バグ報告】 BBS


アクションエディター4に関するご質問やバグ報告はこちらでどうぞ。
※「情報不備」「マナー違反」などの理由で回答できないことがあります。(予告なく削除することもあります)

<ご質問の前に…>
・まずは、オンラインヘルプに載っていないかご確認下さい
・ご質問が既出でないか「ワード検索」から検索をかけて下さい
・応用テクニックに関するご質問にはまともに回答できません。例:「2段ジャンプのやり方を教えて下さい。」
・アクションエディター4で作られたゲームに関するご質問には、ここではお答えできません。そのゲームの作者に問い合わせて下さい

<バグ報告に関して>
・ご使用のOSとプログラム(アクションエディター4本体)のバージョンを明記して下さい


1無題  / 2中立キャラについて v991 (2) / 3ピクチャーとエディター関連 (3) / 4威力が0に設定されているショットや体当たりを食らうとダメージ無効音が再生される (2) / 5無題 (1) / 6パッケージングされるとプレイできない? (3) / 7エディターの「システム」の「シンボル画像の表示に対応」のチェックが保存されない不具合 (3) / 8範囲かグループが偽なら成立とは (1) / 9戻り値の不具合? (3) / 10テストプレイ中にたまに実行中のゲームのアプリがエディターの後ろに隠れる (15) / 11エディターのアイテムでの「ワープ」コマンドが使用できない不具合 (2) / 12専用bmpの横幅が512px未満で起きてしまう不具合 (4) / 13選択肢について (6) / 14メッセージコマンドの設定画面にて (2) / 15リプレイを見た後につづきからを押すとバグる (4) / 16ウイルスソフトの阻害 (4) / 17リフトの動き (4) / 18画像について (5) / 19解像度比率とビルド (3) / 20一度とったら二度と出てこないアイテム (3) /



◆ コモン変数が正常に動きません 投稿者:ウジャB
コモン変数を使って、あるステージで取ったアイテムを
他のステージでも使えるようにしようとしたけれど
うまく継承してくれません。

2009/12/30(Wed) 08:01:01 [ No.1180 ]
◇ Re: コモン変数が正常に動きません 投稿者:アントン
設定ミスの可能性が高いと思います。
解決できない場合、お手数ですがステージをアップして下さい。

2009/12/30(Wed) 09:58:18 [ No.1183 ]
◇ Re: コモン変数が正常に動きません 投稿者:
よく分からないので、
ゲームそのものをアップします。
原因の究明、宜しくお願いします。


添付ファイル 1187.zip (4209kB)

2009/12/30(Wed) 10:33:11 [ No.1187 ]
◇ Re: コモン変数が正常に動きません 投稿者:アントン
不具合を再現する方法を教えて下さい。
どのステージでどのアイテムを取れば良いのか等。

2009/12/30(Wed) 10:35:01 [ No.1188 ]
◇ Re: コモン変数が正常に動きません 投稿者:
ゲームで最初の入り口から
上に進んで少しいったところの
ステージのビッグソードなど、
CやZなどでこうかのあらわれるアイテムをとったあと、
他のステージ(わりとどれでもいい)をプレイすると、
さきほどのステージで取ったアイテムの効果が継承されなくなります。

2009/12/30(Wed) 11:33:46 [ No.1189 ]
◇ Re: コモン変数が正常に動きません 投稿者:アントン
こちらでは継承できました。
具体的には「はじめから」プレイし、そのステージでビッグソードを取ってクリアしたところ他のステージでも大きな剣を振ることができました。
確実な再現手順があれば教えてください。

ひとつ気になったのは、(今回の不具合とは無関係かもしれませんが)現状の設定ですとプレイ中常に(1/10sか2/10s間隔?)でアイテムを取得してしまう点です。
これだと何かしらの不具合が起こっても仕方がない気がします。
ステージ開始直後に1回だけ「アイテムの取得」コマンドを実行させてみてはどうでしょう?例えば「アイテムの取得」コマンドのあとに「このフローの削除」(「フローの操作」コマンドの「削除」)を追加する等。

2009/12/30(Wed) 12:19:35 [ No.1190 ]
◇ Re: コモン変数が正常に動きません 投稿者:
ありがとうございました。
そうしてみます。

2009/12/30(Wed) 12:30:25 [ No.1191 ]

◆ アクセスを許可されていないパソコンがある 投稿者:1252
アクセスを許可されていないぱそこんがありました

2009/12/29(Tue) 17:49:45 [ No.1175 ]
◇ Re: アクセスを許可されていないパソコンがある 投稿者:アントン
トップページに書いてあるとおり、しつこい荒らしのホストと被っているためアクセスできません。
ご了承下さい。

2009/12/29(Tue) 23:15:36 [ No.1178 ]

◆ Direct3Dについて 投稿者:pike
アクションエディター4の更新等お疲れ様です。
期待通りパワーアップしていて嬉しい限りです^^

早速質問で申し訳ないんですが、Direct3DをONにすると速度が遅くなってしまいます。(FPS44〜50)あと文字がぼやけ気味になります。更にゲームの起動までが遅い。

PCのスペックは
OS:XP SP3
CPU:Celeron 1.3Ghz
RAM:768MB
VRAM:Intel 82852/82855 GM/GME GraphicsController 64MB(メインメモリと共有)

もちろんDirectDraw時はFPS60を維持しており、とても満足して使っております。
ビデオカードの問題なんでしょうか?
なにしろ数世代前のノートPCですので^^;

おかしな質問でスイマセンm(_ _)m

2009/12/25(Fri) 22:20:35 [ No.1156 ]
◇ Re: Direct3Dについて 投稿者:アントン
なんとパワーダウンしてしまいましたか…

FPS44〜50というのはどのシーンでのFPSでしょうか?タイトル画面とか。
また、DirectDrawの32bitでは同じ状況でFPSはいくつくらい出て起動時間はどうなるでしょうか?(System.iniで「Direct3D=0」、「Bpp=32」)
お手数ですがDirect3Dを有効にした場合のレポートファイル「Report_Game.txt」もアップして下さい。

2009/12/25(Fri) 22:45:15 [ No.1157 ]
◇ Re: Direct3Dについて 投稿者:バカ・キング
横槍ですが私の状態をば

Direct3Dを有効にしているとデフォルトのデータであろうと高確率で起動に失敗します。
テクスチャの生成に失敗!メモリが足りません!といったエラーを吐いて落ちます。稀にうんともすんともいわず落ちることも。
空きメモリ量は特に問題ありません。Direct3Dのテストツールも試してみましたが正常でした。

レポートファイルのエラーは二通りありました。エラーをはいて落ちる場合が前者、何もいわずに落ちる場合が後者だったと思います。

D3DXCreateTextureFromFileEx Err hr = 8876017c ←大量
D3DXCreateTexture Err hr = 8876017c
err V[0] ( 0 , 1296 )

または

err V[52] ( 52 , 16 ) のみ


1度だけデフォルトのデータで起動に成功したことがありましたが最初の画面ですらFPSが半分も出ていませんでした。3Dを切った状態ではいつもの速度が出ました。

2009/12/25(Fri) 22:56:32 [ No.1158 ]
◇ Re: Direct3Dについて 投稿者:pike
「Direct3D=0」「Bpp=32」時は常時FPS62というBpp=0より速くなってます。起動時間は3秒以内。

Direct3D時に遅くなるのはすべてのシーンです。
タイトル画面は30前後
スクロールしない狭いステージでも40行かないことも…
起動時間は30秒以上です。

ためしにウィンドウモードでも起動してみたところ、
タイトル画面では45、ステージでは44ぐらいから最大52まで出ました。起動時間は同じく30秒ほど掛かります。


添付ファイル 1159.txt (0kB)

2009/12/25(Fri) 23:07:52 [ No.1159 ]
◇ Re: Direct3Dについて 投稿者:アントン
>バカ・キング様
貴重な情報をありがとうございます。
正直Direct3Dの経験が浅いので助かります。
お手数ですがレポートファイルをアップして下さいませんか?

>pike様
残念ながらビデオカードがDirect3Dに完全に対応していないようです。
ビデオカードのドライバを更新すると解消される可能性が少しはあります。
今は起動はできてもDirect3Dの機能を十分に使えていない状態なので、次のバージョンからは、それを判別してDirectDrawへ自動で切り替えるようにしたいと思います。

2009/12/25(Fri) 23:51:43 [ No.1160 ]
◇ Re: Direct3Dについて 投稿者:pike
なるほど!やはり性能不足ですか。
更新すると問題が発生するので諦める事にしますね。
どうしても使いたい時があれば素直に新しいPCを買います^^;
ありがとうございました。
お体には気をつけて!

2009/12/26(Sat) 00:01:45 [ No.1161 ]
◇ Re: Direct3Dについて 投稿者:バカ・キング
レポートファイルです。エラー情報が少ない方のファイルは紛失してしまっているので片方だけですがエラー部分以外は変わらなかったと思います。

うちのPCももう5年以上前のものですし見た感じpikeさんとほとんど変わらないので同じくビデオカードが対応していないのかもしれません。


添付ファイル 1162.txt (1kB)

2009/12/26(Sat) 00:25:41 [ No.1162 ]
◇ Re: Direct3Dについて 投稿者:アントン
アップ感謝です。
初期化の仕方を変えるとかまだこちらでやれることはありそうです。善処します。

2009/12/26(Sat) 00:58:26 [ No.1163 ]
◇ Re: Direct3Dについて 投稿者:3S
突然ですが、こちらの状態をいいます。

フルスクリーン時Direct3Dを有効のすると、
「ワールドマップ」「アクション画面」の時、
画面が乱れ(?)ほぼ全体が真っ黒になってしまいます。
FPSは正常の数値です。起動などが遅いわけでもありません。
ウインドウモードでは全部正常に動作されます。
あと、この状態は確実に起こります。

レポートを提出します。


添付ファイル 1164.txt (0kB)

2009/12/26(Sat) 09:30:47 [ No.1164 ]
◇ Re: Direct3Dについて 投稿者:アントン
ありがとうございます。
これも参考にさせていただきます。

2009/12/26(Sat) 10:10:32 [ No.1165 ]
◇ Re: Direct3Dについて 投稿者:pike
どれもXPの情報なので、今度はVista(別のPC)で試してみました!
相変わらずノートPCなんですが…^^;

デフォルトステージではFPSがなんと20!(笑
タイトル画面では50前後。
更にc01-2をプレイしたところ、FPS10。
スズキ君が超スローモーションです。

レポートを提出しておきます。


添付ファイル 1166.txt (0kB)

2009/12/26(Sat) 12:57:01 [ No.1166 ]
◇ Re: Direct3Dについて 投稿者:アントン
Vista世代のPCでも駄目ですか。
ショックがでかいw
次のバージョンではもう少し詳しい情報をレポートファイルに出力したいと思います。

2009/12/26(Sat) 13:18:43 [ No.1167 ]
◇ Re: Direct3Dについて 投稿者:聖馬
WinXPですが常時FPSが30〜10ぐらいなので報告。

App : ver 400
OS : Windows XP Service Pack 3 PID 2 Build 2600
DirectX : 900
CPU : GenuineIntel Intel(R) Pentium(RP[f 1993
Mem Total : 2047.484MB
Mem Free : 1020MB
Vir Total : 2047.875MB
Vir Free : 2010MB
HD Free : 2048MB
Device HAL-HARD

きっとメモリが足りないかうちのパソがD3Dに対応してないんだと思いますがやばいので一応。
ちなみにデフォステでFPS20〜30。友人向け自作ゲーじゃ
5〜10だったり。

2009/12/26(Sat) 15:10:39 [ No.1168 ]
◇ Re: Direct3Dについて 投稿者:pike
Vistaといっても、エアロ等グラフィック関係が弱いものなのであまり参考にならないかもしれませんが…
デスクトップもオンボードばっかしで参考に出来そうなものが少なくて申し訳ない。

2009/12/26(Sat) 22:53:53 [ No.1169 ]
◇ Re: Direct3Dについて 投稿者:アントン
おはようございます。

具合の悪い方は全員シングルコアCPUでしたので、こちらで(マルチコアならFPS60で動く環境で)シングルコアに落としてみたところ、確かに極端に遅くなりました。
意識はしていなかったのですが、結果的にマルチコアでしかまともに動作しないプログラムになってしまっていたようです。
これを踏まえて近日中にアクエディ4を更新します。

皆様のレポートのおかげでわかりました。
ありがとうございました。

2009/12/27(Sun) 09:52:54 [ No.1170 ]

◆ 分身しすぎ… 投稿者:30万円
ちょっと何が何だか分からないことが起きました。

分身のフローとか何も設定してないのにすごい分身して
全然画面が分からなくなったんです。

これってバグなんでしょうか?

誰か教えてください><

2009/12/22(Tue) 14:10:23 [ No.1147 ]
◇ Re: 分身しすぎ… 投稿者:アントン
2.71より前のバージョンですと、ステージの背景が1つも設定されていないとき、キャラ等の残像が残り続けて画面がグチャグチャになります。
恐らくそのせいではないでしょうか?
背景を1つ以上設定するかアクションエディター4本体を最新版にしてみて下さい。

2009/12/22(Tue) 15:44:31 [ No.1148 ]
◇ Re: 分身しすぎ… 投稿者:30万円
ですが、画面グチャグチャになっていたコースには
背景が設定されていましたし…

バージョンだって最新版をダウンロードってやったんです。
確か、二日まえぐらいに。

なので、バージョンも背景も、原因には当てはまらないかと…

2009/12/22(Tue) 16:58:32 [ No.1149 ]
◇ Re: 分身しすぎ… 投稿者:30万円
引用:ですが、画面グチャグチャになっていたコースには
背景が設定されていましたし…

バージョンだって最新版をダウンロードってやったんです。
確か、二日まえぐらいに。

なので、バージョンも背景も、原因には当てはまらないかと…
:引用
確認:ダウンロードして、それでちょっと複雑になって、「初めからまたやろう」ってなって、またダウンロードしたんです。それが二日前なので、
やはりバージョンは原因には当てはまらないと思います。

2009/12/22(Tue) 17:18:42 [ No.1150 ]
◇ Re: 分身しすぎ… 投稿者:アントン
情報が少なすぎて何ともいえません。
バグが再現可能なファイルをアップして下されば原因を特定できるかもしれません。

2009/12/22(Tue) 17:54:25 [ No.1151 ]
◇ Re: 分身しすぎ… 投稿者:30万円
こっちではやはりなりました。

添付ファイル 1152.rpl4_284 (160kB)

2009/12/22(Tue) 18:41:38 [ No.1152 ]
◇ Re: 分身しすぎ… 投稿者:アントン
アップありがとうございます。
背景が設定されていないようです。(最新版でも駄目なケースがあるようです…)
「ステージの設定」で背景を1つ以上設定して下さい。
「最初から表示」にチェックが入っているかどうか、背景画像を指定している場合パスが不正でないか(ファイル名と一致しているか等)もご確認下さい。
それでも駄目な場合、お手数ですがステージファイルをアップして下さい。

2009/12/22(Tue) 22:58:31 [ No.1153 ]
◇ Re: 分身しすぎ… 投稿者:30万円
ご協力ありがとうございました!

最初から表示にはチェックがついてたので
背景を変えてみました。
そしたらあのバグ(?)は起きませんでした。

これで気楽に作れます!

2009/12/23(Wed) 08:15:09 [ No.1154 ]
◇ Re: 分身しすぎ… 投稿者:30万円
あれ?

画面ぐちゃぐちゃになった背景をもう一回使用してみたら
なにも起きませんでした。

2009/12/23(Wed) 08:20:01 [ No.1155 ]

◆ 右下の 投稿者:ぶーとんとん
右下の「FP1391(02)」やらなんやら
書いてあるものって消すことは出来ますか?

ほんとに何度も質問してすいません!

2009/12/13(Sun) 19:40:29 [ No.1138 ]
◇ Re: 右下の 投稿者:1口
System→ShowFpsの値を0にしましょう。(全角は駄目)

2009/12/16(Wed) 22:36:47 [ No.1139 ]
◇ Re: 右下の 投稿者:ぶーとんとん
1口さん、ありがとうございます。

2009/12/18(Fri) 19:41:55 [ No.1140 ]

◆ ブロックキャラ連続処理 投稿者:αY
タイミングで、主人公に乗られているときの処理で、フローが、何個かかきこんで、そのキャラを連続(横)にして 配置した後、1つ目のキャラは正常に処理しますが、2つめ以降は、
処理がうまく出来ません。

2009/12/06(Sun) 14:20:26 [ No.1125 ]
◇ Re: ブロックキャラ連続処理 投稿者:アントン
ありがとうございます。
こちらで試したところ問題なく動作しました。
バグが再現可能なファイルをアップして下さると助かります。

2009/12/07(Mon) 09:13:50 [ No.1126 ]
◇ Re: ブロックキャラ連続処理 投稿者:K_ URL
同じような状態にこちらもなりました
主人公が乗ったら一定時間で落下するキャラブロックを横に並べてブロックの一つに乗った状態で隣のブロックに歩いて乗ったらフローが動かず・・・
キャラが乗ってる時にした場合は一応乗り続ければ一定時間で落下したのですが主人公が乗ったらの場合乗り続けても何も起こりませんでした
チェックをお願いします

2009/12/12(Sat) 21:24:56 [ No.1127 ]
◇ Re: ブロックキャラ連続処理 投稿者:勇者ああああ
こちらは乗ったら一定時間で爆発するブロックを作ったんですが、やはり同じ状態になりました。
で、いろいろ試行錯誤してたらある発見がありました。
地続きになってるのが原因なのかと思い、ブロックを数ドット上昇させて無理矢理段差を作ってみたんです。
↓のようにやれば再現できるはず。

□■□

□=普通のブロックキャラ
■=数ドット上昇させるブロックキャラ

そしてブロックに乗ってから移動してみると、なんと主人公が浮いてしまったんです。
4ドット浮かせるとよくわかると思います。ちなみに5ドット以上だと普通に落ちました。
乗ったかどうかの判定以前にそもそも乗ってないのがバグの実態みたいですね。

2009/12/13(Sun) 11:23:00 [ No.1131 ]
◇ Re: ブロックキャラ連続処理 投稿者:アントン
後日修正します。
これを直すと弊害が出る気もしますが直さないわけにはいかないですね。

2009/12/13(Sun) 12:57:30 [ No.1135 ]

[1] [2] [3] [4] [5] [6] [7] [8] [9] [10] [11] [12] [13] [14] [15] [16] [17] [18] [19] [20] [21] [22] [23] [24] [25] [26] [27] [28] [29] [30] [31] [32] [33] [34] [35] [36] [37] [38] [39] [40] [41] [42] [43] [44] [45] [46] [47] [48] [49] [50] [51] [52] [53] [54] [55] [56] [57] [58] [59] [60] [61] [62] [63] [64] [65] [66] [67] [68] [69] [70] [71] [72] [73] [74] [75] [76] [77] [78] [79] [80] [81] [82] [83] [84] [85] [86] [87] [88] [89] [90] [91] [92] [93] [94] [95] [96] [97] [98] [99] [100] [101] [102] [103] [104] [105] [106] [107] [108] [109] [110] [111] [112] [113] [114] [115] [116] [117] [118] [119] [120] [121] [122] [123] [124] [125] [126] [127] [128] [129] [130] [131] [132] [133] [134] [135] [136] [137] [138] [139] [140] [141] [142] [143] [144] [145] [146] [147] [148] [149] [150] [151] [152] [153] [154] [155] [156] [157] [158] [159] [160] [161] [162] [163] [164] [165] [166] [167] [168] [169] [170] [171] [172] [173] [174] [175] [176]

処理 記事No 削除キー

- Joyful Note Antispam Version -


トップ > サポート > アクションエディター4 【質問・バグ報告】 BBS